
<!DOCTYPE html>
<!--==================================================
==================START: HEADER====================-->
<html lang="en">
	<head>
		
		<!--
macro: mainmeta (MCD 201610140350)
current date: 20200929022058
template: 
currentrequest: /apps/pbcs.dll/article?avis=CO&date=20200928&category=SPORTS&lopenr=200929798&Ref=AR
currentrequestunmodified: /sports/20200928/driskel-benched-broncos-fall-to-0-3-after-loss-to-bucs
@templatetype: /apps/pbcs.dll/article?avis=CO&date=20200928&category=SPORTS&lopenr=200929798&Ref=AR
@pagetype: article
app version: 2.0.477
-->
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="Fowler Tribune - Fowler, CO" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<meta name="msvalidate.01" content="7E15F9269E2CE66F2A488ABB04B5015E" />

		<title> Driskel benched, Broncos fall to 0-3 after loss to Bucs - Sports - Fowler Tribune - Fowler, CO - La Junta, CO</title>
<!-- Meta Tags - Global Article6 guid: 615F47AD-BF2A-4F3B-811B-840D21DE055D-->
<meta name="description" content="DENVER (AP) &mdash; Jeff Driskel benched. Early punt blocked. Defense Tom Brady-ied.That pretty much wraps up how the day went for the struggling Denver Broncos, who fell 28-10 to Brady and the Tampa Bay Buccaneers on Sunday.For the second straight season, the Broncos start 0-3.For the second straight September, coach Vic Fangio went winless, which is something no other coach in the Broncos&rsquo; history has done. His team was 0-4 in the month last season.&quot;We&rsquo;ve just all got to look in" />
<meta property="bt:pubDate" content="20200928T10:30:44Z">
<meta property="bt:modDate" content="20200928T10:30:00Z">
<meta property="bt:author" content="Jeff Letofsky">
<meta name="twitter:title" content="Driskel benched, Broncos fall to 0-3 after loss to Bucs">
<meta name="twitter:description" content="DENVER (AP) &mdash; Jeff Driskel benched. Early punt blocked. Defense Tom Brady-ied.That pretty much wraps up how the day went for the struggling Denver Broncos, who fell 28-10 to Brady and the Tampa Bay Buccaneers on Sunday.For the second straight season, the Broncos start 0-3.For the second straight September, coach Vic Fangio went winless, which is something no other coach in the Broncos&rsquo; history has done. His team was 0-4 in the month last season.&quot;We&rsquo;ve just all got to look in">
<meta property="og:title" content="Driskel benched, Broncos fall to 0-3 after loss to Bucs"/>
<meta property="og:description" content="DENVER (AP) &mdash; Jeff Driskel benched. Early punt blocked. Defense Tom Brady-ied.That pretty much wraps up how the day went for the struggling Denver" />
<meta name="author" content="Jeff Letofsky">
	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:image" content="https://www.fowlertribune.com/storyimage/CO/20200928/SPORTS/200929798/AR/0/AR-200929798.jpg&MaxW=1200&MaxH=630">
	<meta property="og:image" content="https://www.fowlertribune.com/storyimage/CO/20200928/SPORTS/200929798/AR/0/AR-200929798.jpg">
	<meta property="og:image:width" content="512">
	<meta property="og:image:height" content="341">
	<meta property="vf:unique_id" content="siteCO-pub249-615F47AD-BF2A-4F3B-811B-840D21DE055D">
	<link rel="canonical" href="https://www.fowlertribune.com/sports/20200928/driskel-benched-broncos-fall-to-0-3-after-loss-to-bucs"/>
<link rel="amphtml" href="https://www.fowlertribune.com/sports/20200928/driskel-benched-broncos-fall-to-0-3-after-loss-to-bucs?template=ampart">
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.fowlertribune.com/sports/20200928/driskel-benched-broncos-fall-to-0-3-after-loss-to-bucs"
	},
    "headline": "Driskel benched, Broncos fall to 0-3 after loss to Bucs",
    "image": {
       "@type": "ImageObject",
       	"url":"https://www.fowlertribune.com/storyimage/CO/20200928/SPORTS/200929798/AR/0/AR-200929798.jpg",
       	"height": 341,
       	"width": 512
    },
    "url": "https://www.fowlertribune.com/article/20200928/SPORTS/200929798",
    "thumbnailUrl": "https://www.fowlertribune.com/apps/pbcsi.dll/bilde?Site=CO&Date=20200928&Category=SPORTS&ArtNo=200929798&Ref=AR",
    "dateCreated": "20200928T17:30:44Z",
    "datePublished": "20200928T17:30:44Z",
    "dateModified": "20200928T17:30:00Z",
    "author": [{"@type":"Person","name":"Jeff Letofsky"}],
    "creator": "Jeff Letofsky",
    "publisher": {
       "@type": "Organization",
       "name": "Fowler Tribune - Fowler, CO",
       "logo": {
         "@type": "ImageObject",
         "url": "https://www.fowlertribune.com/Global/images/head/nameplate/fowlertribune_logo.png"
       }
    },
    "articleSection": "Sports",
    "keywords": ["Football","Redesign: Below Featured","CO_Pueblo - chieftain.com"],
    "isAccessibleForFree": "false",
	"hasPart":
	{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paywall-is-accessible-for-free"
	},
	"isPartOf": {
    "@type": ["CreativeWork", "Product"],
    "name" : "Fowler Tribune",
    "productID": "fowlertribune.com:standard"
	}
  }
</script>
<meta property="fb:app_id" content="240394462647837"/>
<meta property="og:type" content="article"/>
<meta property="article:opinion" content="false"/>

		<script type="text/javascript">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</script>
				        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700|Roboto+Condensed:400,400i,700,700i|Crimson+Text:400,400i,700,700i|Rubik:400,500,700,900" crossorigin="anonymous" />
        <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css" crossorigin="anonymous" />
        <link rel="stylesheet" href="//cdn.gatehousemedia.com/assets/css/2.0.477/default.min.css" type="text/css" crossorigin="anonymous" />
		<style type="text/css">
	#toprail-microbar{
		z-index:1000;
	}
	/*legacy-header*/
	.legacy-header #baseLeaderboard {
		margin-top:25px;
	}
	#header-content div#slidingBillboard.ad.text-center {
		padding: 0;
		margin: 0;
	}
	#article > div > section.article-v2-left > div.ad-container { clear: both; }
	@media only screen and (max-width: 768px) {
		#buckets > div.article-extra > h4.chatter-title {
		    font-size: 2em;
		}
	}
	section.article-v2-right > div.article-body.p402_premium > div.vendor-logo.byline-item > img{
		max-width: 150px;
	}
	#apoc-breaking-wrapper{position: relative;z-index:100;}
	article.summary .inner .related li {max-height:fit-content!important;}
    /*==== ARTICLE ======*/
    .ad-300x250{
	    height: auto !important;
    }
    .pgs-dpg-flex, .pgs-dpg-card, div.pgs-dpg-card > iframe, div.pgs-dpg-flex > iframe{
		max-width: 350px;
		max-height: 460px;
		overflow: hidden;
	}
		/*==== for taboola ======*/
    	.article-newsletter-signup,#dialog-message{
	    	display: none !important;;
    	}
    	@media only screen and (min-width: 768px) {
			#interstitial{display:none;}
		}
    	/*story strip article ad*/
    	/* cssUpdates branch*/
    	div.gh-slider-storyStrip > div.adInject > div > iframe {
			max-height:90px;
		}
    	/* cssUpdates branch*/
    	.gh-slider-caption h3:not(.is-truncated):not([style="word-wrap: break-word;"]){
			-webkit-line-clamp: 4;
		    text-overflow: ellipsis;
    	}
    	.article-meta-day,a:visited  {
			font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
			font-size: 18.662px;
			font-weight: bold;
			color: #698096;
			display: block;
			font-kerning: normal;
			text-rendering: optimizeLegibility;
			margin-bottom: 10px;
			text-decoration: none;
		}
		#flipp-promo {
		    max-width: 300px;
		    margin: 0 auto;
		    max-height: 250px;
		 }
    	/* Viafoura email & password fields in registration/signup screens */
	 	.viafoura .vf-forgot-pw-link, .viafoura .vf-account-form {
	 		display: none;
	 	}
    	/*  TERMS OF SERVICE LINK - under viafoura comments submit button */
    	.vf-terms-of-service { margin-left: 12px;}
		/* TOUT MID ARTICLE PLAYER */
		.tout-mid-article { display:block; margin-right:2.35%; width:100%; }
	/* MOBILE article story stack */
    .gh-article-storyStack {
        background-color: #f3f3f3;
        display: inline-block;
        width: 100%;
        height: 150vw;
    }
    .gh-stacked {
        display: inline-block;
        padding: 2vw 2vw 4vw 2vw;
        margin: 0 0 3vw 0;
        height: 25vw;
        width: 100%;
    }
    .gh-stacked figure {
        width: 20vw;
        height: 20vw;
        display: inline-block;
        float: left;
        /* margin: 0 3vw 0 0; */
    }
    .gh-stacked h3 {
        width: calc(100% - 4.8em - 1.618em);
	    font-size: 1.25em;
	    line-height: 1.3em;
	    float: left;
	    display: inline;
    }
    .gh-article-storyStack .slick-slide .image{min-height:80px !important;}
    .gh-article-storyStack .slick-slide a{display:block;height:100%;width:100%;border-bottom: 1px solid #454545;margin-bottom:5px;}
</style>
		<style>
@media screen and (min-width: 768px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:lightskyblue;}
}
@media screen and (max-width: 767px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:#039be5;}
}
</style>
				<script type="text/javascript">
			window.supportsLocalStorage = false;
			try {
				window.supportsLocalStorage = !!window.localStorage
				    && typeof localStorage.getItem === 'function'
				    && typeof localStorage.setItem === 'function'
				    && typeof localStorage.removeItem === 'function';
			} catch(e) {
				console.error('localStorage error', e);
			}
			if(window.supportsLocalStorage === false) {
				console.warn('localStorage is not supported on this browser.');
			}
		</script>
		<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js?20160411-3" crossorigin="anonymous"></script>
		<!-- Google Tag Manager -->
<script>
  //PAGE DATA
  __gh__coreData.pageData.type2 = "Article";
  __gh__coreData.pageData.error = __gh__coreData.pageData.type2 == "404" ? "404" : undefined;
  //USER
  __gh__coreData.user = {id:undefined,accessLevel:undefined};
  // Get clientside pieces from LocalStorage object
  if (window.supportsLocalStorage === true && typeof localStorage['_vxData'] != "undefined"){
    var _vxDataObj = JSON.parse(localStorage['_vxData']);
    __gh__coreData.user				= _vxDataObj;
  }
  //define main dataLayer for object for GTM
  window.dataLayer 	= window.dataLayer || [];
  dataLayer.push(__gh__coreData);
var __gh__gtm = {
	id:'GTM-WF5MZJ9'
};
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',__gh__gtm.id);
</script>
<!-- End Google Tag Manager -->
		<script async='async' src='//cdn.adsafeprotected.com/iasPET.1.js'></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/gannett-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
		<!--[if lte IE 9]>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv-printshiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
		<![endif]-->
		<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "9289482" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "https://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://b.scorecardresearch.com/p?c1=2&c2=9289482&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

		
	</head>
<!--================================================
==================END: HEADER====================-->

	<body class="__PAGETYPE__">
		
	<div id="fb-root"></div>
	
		<a href="#" id="backToTop"><i class="fa fa-chevron-up"></i></a>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WF5MZJ9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<div id="wrapper-main">
			
					<header id="header-main" class="header header-expanded no-gutter static clearfix">
			<div id="toprail">
	<div class="inner clearfix">
		<a id="button-nav-toggle"
			title="Navigation menu">
			<span class="hidden-sm hidden-xs">Sections</span>
			<i class="fa fa-fw fa-bars"></i>
		</a>
			<ul id="toprail-nav-left" class="list-inline"><li><a href="https://www.fowlertribune.com/news" target="_top">News</a></li><li><a href="https://www.fowlertribune.com/sports" target="_top">Sports</a></li><li><a href="https://www.fowlertribune.com/entertainment" target="_top">Entertainment</a></li><li><a href="https://www.fowlertribune.com/lifestyle" target="_top">Life</a></li><li><a href="https://www.fowlertribune.com/obituaries" target="_top">Obituaries</a></li><li><a href="https://www.fowlertribune.com/section/cars" target="_top">Cars</a></li><li><a href="https://www.fowlertribune.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.fowlertribune.com/homes" target="_top">Homes</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/Colaj" target="_top">Classifieds</a></li></ul>
		<ul id="toprail-nav-right" class="list-inline">
				<li id="toprail-subscribe"><a href="https://www.fowlertribune.com/subscribe?g2i_source=fowlertribune.com&g2i_medium=subscribe&g2i_campaign=topRail" target="_top" class="btn btn-sm btn-subscribe hidden-lg">Subscribe</a></li>
			<li id="toprail-search" class="hidden-sm hidden-xs">
											<div id="toprail-search-form">
								<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
									<script type="text/javascript">
	function searchArchive(archval){
		if(archval == 'archive'){
			document.location.href = 'http://nl.newsbank.com/nl-search/we/Archives?p_product=FTCO&p_theme=gatehouse&p_action=keyword';
		}else{
			return false;
		}
	}
</script>
<div class="input-group-btn">
	<button type="button" class="btn btn-default dropdown-toggle" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"><span class="caret"></span></button>
	<ul class="dropdown-menu" id="searchparam_dd">
		<li data-type="site" class="selected">Site</li>
<li data-type="archive">Archive</li>
	</ul>
</div><!-- /btn-group -->
<script>
$(document).on('click', '#searchparam_dd li', function() {
	searchArchive($(this).data('type'));
});
</script>
									<input class="search-input" name="searchText" placeholder="Search this site" type="search">
									<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
								</form>
							</div>
							<i class="fa fa-fw fa-lg fa-search"></i>
			</li>
				<li id="toprail-weather" class="hidden-xs" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.fowlertribune.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#toprail-weather"></li>
		</ul>
		<div id="toprail-microbar">
			<div class="ad text-center">
				<div class="ad ad-topbanner text-center" data-gh-lazy-ad-bucket-targeting='{"ad-type":"standard","slot":"Base Micro Bar","sov":"base ROS","allow_adx":"false"}' id="topBarSponsor" data-dimensions="[88,31]"></div>
			</div>
		</div>
	</div>
</div>
						<div id="header-main-nameplate">
				<div id="header-main-left">
					<div id="header-main-logo">
						<a href="https://www.fowlertribune.com">
							<img class="mainheadnameplate" src="https://www.fowlertribune.com/Global/images/head/nameplate/fowlertribune_logo.png"  alt="Fowler Tribune - Fowler, CO" />
						</a>
					</div>
				</div>
				<div id="header-main-center">
					<a href="https://www.fowlertribune.com/subscribe?g2i_source=fowlertribune.com&g2i_medium=subscribe&g2i_campaign=header" target="_top" class="btn btn-subscribe">Subscribe Now</a>
				</div>
				<div id="header-main-right" class="hidden-xs">
					<div id="header-main-promo" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.fowlertribune.com/section/?template=ajaxPromoWiz7" data-gh-fetch-html-dom="#header-main-promo"></div>
				</div>
			</div>
		</header>


<!--==================================================
==========================START: CONTENT===========-->
			<div id="content" class="clearfix">
				

<div class="alert"></div>
<div id="apoc-breaking-wrapper" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.fowlertribune.com/section/breaking_ajax?template=breaking_ajax2" data-gh-fetch-html-dom="#apoc-breaking-wrapper"></div>
<div data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://cdn.gatehousemedia.com/gh-sites/global/breaking/breaking-special.html"></div>

				<div class="ad ad-billboard text-center" id='ad-base-leaderboard-article'>
	<div id="baseLeaderboard" data-size-mapping="baseLeaderBillboardArticle"></div>
	<div data-gh-object-loaded="false" 
		data-gh-object-offset="0" 
		data-secondLevel-7103="leaderboard_atf"
	data-secondLevel-mobile-7103="mobileweb-banner_top" 
			data-gh-object='{"method":"__gh__webApp.utilities.adsRefresh.init","data":{"id":"baseLeaderboard-adRefresh","orgId":"baseLeaderboard","loadNow":"false","container":"ad-base-leaderboard-article"}}'
				class="ad-refresh" 
					data-gh-lazy-ad-bucket-targeting='{"ad-type":"standard","slot":"Base Leaderboard","sov":"base ROS","refresh":"true"}' 
						data-dimensions="[[970,90],[970,250],[728,90]]" 
							id="baseLeaderboard-adRefresh" 
							 data-size-mapping="baseLeaderBillboardArticle" 
								 data-gh-object-parent-height="true"></div>
</div>

				<div id="wrapper" class="clearfix">
					<div id="buckets">
	<article class="full article-v2 loading" data-updated="20200928103044">
	<div class="inner">
		<h1 class="headline">Driskel benched, Broncos fall to 0-3 after loss to Bucs</h1>
		<section class="article-v2-left">&nbsp;</section>
		<section class="article-v2-right">
			        <figure class="thumb">
            <img class="image" src="https://www.fowlertribune.com/storyimage/CO/20200928/SPORTS/200929798/AR/0/AR-200929798.jpg&MaxH=200&MaxW=200" width="100%">
            <!--div class="image-caption">
                <div class="description">Denver quarterback Jeff Driskel scrambles under pressure from Tampa Bay nose tackle Vita Vea, left, and defensive end Ndamukong Suh, right, during the first half on Sunday at Empower Field at Mile High in Denver. [AP Photo/David Zalubowski]</div>
                <div class="credit">David Zalubowski</div>
            </div-->
        </figure>
			<div class="article-body">
				<span class="byline-item">
					Jeff Letofsky Interim Sports Editor   @JeffLetofsky
				</span>
				<div class="article-meta">
					<div class="inner">
						<div class="article-meta-main">
							<h3 class="article-meta-day">Monday</h3>
							<span class="article-meta-date">Sep&nbsp;28,&nbsp;2020&nbsp;at&nbsp;10:30&nbsp;AM</span>
							<span class="article-meta-updated"></span>
						</div>
					</div>
				</div>
				<br><br>
				<div class="inner">
					<p class="article-summary"></p>
					<p><p>DENVER (AP) &mdash; Jeff Driskel benched. Early punt blocked. Defense Tom Brady-ied.</p><br><p>That pretty much wraps up how the day went for the struggling Denver Broncos, who fell 28-10 to Brady and the Tampa Bay Buccaneers on Sunday.</p><br><p>For the second straight season, the Broncos start 0-3.</p><br><p>For the second straight September, coach Vic Fangio went winless, which is something no other coach in the Broncos&rsquo; history has done. His team was 0-4 in the month last season.</p><br><p>"We&rsquo;ve just all got to look in the mirror and just figure it out because we&rsquo;re way too talented to be 0-3," said Broncos receiver Tim Patrick, who had a 7-yard TD catch just before halftime to make it 23-10. "We&rsquo;re way too talented to be losing these games."</p><br><p>It wasn't pretty in any facet for the Broncos as Brady picked up his first road win for the Bucs (2-1). It's been a rough stretch for the Broncos, who are missing quarterback Drew Lock, standout pass rusher Von Miller, top receiving threat Courtland Sutton and running back Phillip Lindsay.</p><br><p>Stepping in for Lock, Driskel was under constant duress. He was sacked five times, including twice by former Bronco and reigning NFL sack leader Shaq Barrett. Driskel finished 17 of 30 for 176 yards, one TD and an interception. He was also tackled in the end zone by Barrett for a safety.</p><br><p>In the fourth quarter, Driskel got pulled in favor of Brett Rypien, who was activated off the practice squad Friday.</p><br><p>Rypien completed eight straight passes to start his NFL career. His ninth was complete as well &mdash; only to safety Mike Edwards in the end zone to thwart a drive.</p><br><p>"Wish we could have gotten that one back and got the touchdown," said Rypien, who's the nephew of longtime NFL quarterback Mark Rypien. "I think I&rsquo;ve made some big strides as far as understanding defenses better and knowing when to get the ball out."</p><br><p>The Broncos have a full-fledged QB controversy &mdash; on a short week, too. They play on the road against the Jets on Thursday.</p><br><p>The options: Stick with Driskel, turn to Rypien or trot out recently signed Blake Bortles, who may not be fully up-to-date on the system but does have 103 touchdown pass &mdash; along with 75 interceptions &mdash; on his resume.</p><br><p>Fangio didn't tip his hand after the game.</p><br><p>"We&rsquo;ll talk about it as a staff and move forward," he said.</p><br><p>It was out of Driskel's hands, so he wasn't going to dwell on it, either.</p><br><p>"I hope to be out there," Driskel said. "I expect to be out there."</p><br><p>This wasn't the start the Broncos envisioned: A blocked punt after their opening drive stalled. Tampa Bay's Patrick O'Connor burst through the middle, stuck out his hand while being held and deflected Sam Martin's kick.</p><br><p>Brady was in business at the Denver 10 yard line. Three plays later, he found Chris Godwin for the score.</p><br><p>"It&rsquo;s never good, obviously," Fangio said of the special teams breakdown. "We had a chance to hold it to only a field goal. We needed to do that on defense and didn&rsquo;t get that done."</p><br><p>In all, Brady threw three TD passes and was an efficient 25 of 38 for 297 yards. The Bucs were 8 of 16 on third down.</p><br><p>"At the end of the day, my job is to get to the quarterback and I just have to do that better," pass rusher Bradley Chubb said. "It&rsquo;s frustrating, but we just have to forget about it and bounce back."</p><br><p>The message was that simple.</p><br><p>"We are not where we can be," guard Graham Glasgow said. "Frankly, that is a case for optimism, but at the same time the reality of the situation is that we are underperforming and we&rsquo;re underachieving and that&rsquo;s something that we need to work through as a group and as an offense."</p><br><p>Chubb's sentiment as well.</p><br><p>"Three games doesn&rsquo;t define your season," Chubb said. "We just have to keep sticking together, fighting for each other, and go out there and make the plays we&rsquo;re supposed to make."</p></p>
				</div>
			</div>
		</section>
	</div>
</article>
</div>

				</div><!-- /wrapper -->
			</div><!-- /content -->

			<div id="push-main" class="clearfix"></div>
		</div><!-- /wrapper-main -->
<!--==================================================
====================END: CONTENT===================-->
				<footer id="footer-main" class="clearfix">
			<div class="inner container">
				<div id="footer-main-newsletter">
					<div id="footer-main-subscribe">
						<h2>Never miss a story</h2>
						<p>
							Choose the plan that's right for you.<br>
							Digital access or digital and print delivery.
						</p>
						<a href="https://www.fowlertribune.com/subscribe?g2i_source=fowlertribune.com&g2i_medium=subscribe&g2i_campaign=footer" target="_top" class="btn btn-subscribe">Subscribe Now</a>
					</div>
								<h2>Sign up for daily e-mails</h2>
										<form id="sfNewsletterForm_footer" class="sfNewsletterForm form-inline">
			<input type="email" name="sfUserEmail" class="sfUserEmail" placeholder="Enter Email Address">
			<input type="hidden" name="sfSource" class="sfSource" value="footer">
			<input type="submit" name="sfSignup" class="sfSignup btn btn-newsletter" value="Sign Up Now">
			<div class="sfResults">
			</div>
		</form>
				</div>
				<div id="footer-main-info" data-gh-accordion-loaded="false" data-gh-accordion-panel-dom="#footer-main-info .footer-col ul" data-gh-accordion-toggle-dom="#footer-main-info &gt; .footer-col &gt; h4" data-gh-accordion-open-at="480">	<div class="footer-col"><h4>Site Services<i class="fa fa-angle-down"></i></h4><ul><li><a href="https://supportlocal.usatoday.com" target="_top">Support Local Businesses</a></li><li><a href="http://myprofile.fowlertribune.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=GTAO_FT" target="_top">My Profile</a></li><li><a href="http://mediakit.gatehousemedia.com/LaJunta_CO/" target="_blank">Advertise With Us</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/Colaj" target="_top">Classifieds</a></li><li><a href="http://adportal.marketplaceadsonline.com/gatehouse-adportal/colaj-classified/index.html" target="_top">Place Classified Ad</a></li></ul></div><div class="footer-col"><h4>Community Info<i class="fa fa-angle-down"></i></h4><ul><li><a href="https://www.colorado.gov/crowleycounty" target="_blank">Crowley County</a></li></ul></div><div class="footer-col"><h4>Market Place<i class="fa fa-angle-down"></i></h4><ul><li><a href="https://www.fowlertribune.com/section/cars" target="_top">Cars</a></li><li><a href="https://www.fowlertribune.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li></ul></div><div class="footer-col"><h4>Sports & Recreation<i class="fa fa-angle-down"></i></h4><ul><li><a href="https://www.fowlertribune.com/sports/high-school" target="_top">Crowley County Athletics</a></li></ul></div>
</div><!-- /footer-main-info -->
			</div><!-- /inner++++/apps/pbcs.dll/article?avis=CO&date=20200928&category=SPORTS&lopenr=200929798&Ref=AR -->
			<div id="footer-main-copyright">
					<p id="footer-copyrightInfo">&copy; Gannett Co., Inc. 2020. All rights reserved.</p>
	<p>Original content available for non-commercial use under a Creative Commons license, except where noted.
	<br />Fowler Tribune - Fowler, CO  ~ 422 Colorado Avenue, La Junta, CO 81050<span class="gdpr hide"> ~ <a id="ot-sdk-btn" class="ot-sdk-show-settings" href="javascript:void(0);">Do Not Sell My Personal Information</a> ~ <a href="https://www.fowlertribune.com/section/cookie-policy" target="_blank">Cookie Policy</a></span><span class="gdpr-disabled hide"> ~ <a href="https://www.gannett.com/cookie-policy/" target="_blank">Do Not Sell My Personal Information</a></span> ~ <a href="http://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a> ~ <a href="http://www.gannett.com/terms-of-use/" target="_blank">Terms Of Service</a> ~ <a href="https://www.gannett.com/ccpa/" target="_blank">Your California Privacy Rights / Privacy Policy</a></p>
	<p><a href="/ownership">Gannett | USA TODAY NETWORK</a></p>
			</div>
		</footer><!-- /footer -->
				<nav id="drawer" role="navigation">
			<a href="https://www.fowlertribune.com/subscribe?g2i_source=fowlertribune.com&g2i_medium=subscribe&g2i_campaign=drawer" target="_top" class="btn btn-subscribe">Subscribe Now</a><hr>
			<div id="drawer-search" class="hidden-md hidden-lg">
				<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
					<div class="input-group-btn">
						<button type="button"
							class="btn btn-default dropdown-toggle"
							data-toggle="dropdown"
							aria-haspopup="true"
							aria-expanded="false">
							<span class="caret"></span>
						</button>
						<ul class="dropdown-menu" id="searchparam_dd">
							<li data-type="site" class="selected">Site</li>
							<li data-type="archive">Archive</li>
						</ul>
					</div>
					<input class="search-input" name="searchText" placeholder="Search Site" type="search">
					<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
				</form>
			</div>
			<hr class="hidden-md hidden-lg">
			<div class="inner">
				<div id="wrapper-drawer">
						<ul 
					 class="nav" 
					 data-gh-accordion-loaded="false" 
					 data-gh-accordion-panel-dom="#drawer-nav-sections .subnav" 
					 data-gh-accordion-toggle-dom="#drawer-nav-sections &gt; li &gt; a" 
					 id="drawer-nav-sections"
				   ><li><a href="https://www.fowlertribune.com" target="_top">Home</a></li><li><a href="https://www.fowlertribune.com/news"><span class="nav-category">News</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"5601"><a href="https://www.fowlertribune.com/news/community" target="_top">Community</a></li><li id="navLink-TEST-"5602"><a href="https://www.fowlertribune.com/news/court-news" target="_top">Court News</a></li><li id="navLink-TEST-"5603"><a href="https://www.fowlertribune.com/news/education" target="_top">Education</a></li><li id="navLink-TEST-"5605"><a href="https://www.fowlertribune.com/news/police-fire" target="_top">Police & Fire</a></li><li id="navLink-TEST-"5607"><a href="https://www.fowlertribune.com/news/state-news" target="_top">State News</a></li><li id="navLink-TEST-"5606"><a href="https://www.fowlertribune.com/news/shareable" target="_top">Shareable</a></li></ul></li><li><a href="https://www.fowlertribune.com/sports"><span class="nav-category">Sports</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"5610"><a href="https://www.fowlertribune.com/sports/high-school" target="_top">High School</a></li></ul></li><li><a href="https://www.fowlertribune.com/entertainment"><span class="nav-category">Entertainment</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"5613"><a href="https://www.fowlertribune.com/entertainment/books" target="_top">Books</a></li><li id="navLink-TEST-"5614"><a href="https://www.fowlertribune.com/entertainment/celebrity-news" target="_top">Celebrity News</a></li><li id="navLink-TEST-"5615"><a href="https://www.fowlertribune.com/entertainment/movies" target="_top">Movies</a></li><li id="navLink-TEST-"5616"><a href="https://www.fowlertribune.com/entertainment/music" target="_top">Music</a></li><li id="navLink-TEST-"38408"><a href="https://www.fowlertribune.com/calendar" target="_top">Calendar</a></li></ul></li><li><a href="https://www.fowlertribune.com/lifestyle"><span class="nav-category">Lifestyle</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"52286"><a href="http://www.timeandmoney.com" target="_top">Time and Money</a></li><li id="navLink-TEST-"5620"><a href="https://www.fowlertribune.com/lifestyle/boomers" target="_top">Boomers</a></li><li id="navLink-TEST-"5621"><a href="https://www.fowlertribune.com/lifestyle/faith" target="_top">Faith</a></li><li id="navLink-TEST-"5622"><a href="https://www.fowlertribune.com/lifestyle/family" target="_top">Family</a></li><li id="navLink-TEST-"5623"><a href="https://www.fowlertribune.com/lifestyle/food" target="_top">Food</a></li><li id="navLink-TEST-"5624"><a href="https://www.fowlertribune.com/lifestyle/health" target="_top">Health</a></li><li id="navLink-TEST-"5625"><a href="https://www.fowlertribune.com/lifestyle/home-garden" target="_top">Home & Garden</a></li><li id="navLink-TEST-"5626"><a href="https://www.fowlertribune.com/lifestyle/pets" target="_top">Pets</a></li><li id="navLink-TEST-"5627"><a href="https://www.fowlertribune.com/lifestyle/travel" target="_top">Travel</a></li></ul></li><li><a href="https://www.fowlertribune.com/opinion"><span class="nav-category">Opinion</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"5630"><a href="https://www.fowlertribune.com/opinion/columns" target="_top">Columns</a></li><li id="navLink-TEST-"5631"><a href="https://www.fowlertribune.com/opinion/editorials" target="_top">Editorials</a></li><li id="navLink-TEST-"5632"><a href="https://www.fowlertribune.com/opinion/letters" target="_top">Letters</a></li></ul></li><li><a href="https://www.fowlertribune.com/business-news" target="_top">Business</a></li><li><a href="https://www.fowlertribune.com/obituaries" target="_top">Obituaries</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>More</header><li><a href="https://www.fowlertribune.com/photos" target="_top">Photos</a></li><li><a href="https://www.fowlertribune.com/videos" target="_top">Videos</a></li><li><a href="https://www.fowlertribune.com/calendar" target="_top">Calendar</a></li><li><a href="https://www.fowlertribune.com/contests" target="_top">Contests</a></li><li><a href="https://www.fowlertribune.com/ara" target="_top">Branded Content</a></li><li><a href="https://www.fowlertribune.com/submit" target="_top">Submit your news</a></li><li><a href="https://www.fowlertribune.com/section/promoted//?prx_adpz=2231" target="_top">From Our Advertisers</a></li><li><a href="https://www.fowlertribune.com/southern-kitchen" target="_top">Southern Kitchen</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Subscriber</header><li><a href="http://myprofile.fowlertribune.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=GTAO_FT" target="_top">My Profile</a></li><li><a href="https://www.fowlertribune.com/subscribe" target="_top">Subscribe</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Market Place</header><li><a href="http://mediakit.gatehousemedia.com/LaJunta_CO/" target="_blank">Advertise With Us</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/Colaj" target="_top">Classifieds</a></li><li><a href="https://www.fowlertribune.com/section/cars" target="_top">Cars</a></li><li><a href="https://www.fowlertribune.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.fowlertribune.com/homes" target="_top">Homes</a></li><li><a href="https://www.fowlertribune.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill </a></li><li><a href="http://fowlertribune.thrivehive.com/" target="_blank">Digital Marketing Services</a></li></ul>
<footer id="footer-drawer">
	<hr>
	<ul class="drawer-nav-secondary nav">
		<li>
			<a href="mailto:fowler.editor@ljtribune.com">Feedback</a>
		</li>
		<li>
			<a href="https://www.fowlertribune.com/ownership">Ownership</a>
		</li>
		<li>
			<a href="https://www.gannett.com/terms-of-use/" target="_blank">Terms of Use</a>
		</li>
		<li>
			<a href="https://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a>
		</li>
		<li>
			<a href="https://www.gannett.com/brands/" target="_blank">Gannett Publications</a>
		</li>
	</ul>
</footer>
				</div>
				<footer id="footer-drawer">
					<div id="drawer-weather" class="visible-xs-block text-center" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.fowlertribune.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#drawer-weather">
					</div>
					<ul class="social list-inline">
						<li>
							<a	href="http://www.facebook.com/pages/Fowler-Tribune/134766543293911""
								target="_blank"
								title="Fowler Tribune - Fowler, CO Facebook">
								<i class="fa fa-fw fa-facebook"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.fowlertribune.com/section/feed"
								target="_blank"
								title="Fowler Tribune - Fowler, CO RSS Feed">
								<i class="fa fa-fw fa-rss"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.fowlertribune.com/contact"
								title="Contact Fowler Tribune - Fowler, CO">
								<i class="fa fa-fw fa-envelope"></i>
							</a>
						</li>
					</ul>
					<!-- <span id="drawer-copyrightInfo">&copy; 2015 __SITENAME__</span> -->
				</footer>
			</div><!-- /.inner -->
		</nav>
		<div id="drawer-fade-screen"></div>
		<div id="dialog-message" data-gh-object-loaded="false" data-gh-object='{"method":"__gh__webApp.messageCenter.load","data":{"storageKey":"messageCenter"}}' class="slideUp hide">
    <header>
        <h3 class="dialog-title">SUBSCRIBE TODAY</h3>
        <div class="dialog-controls">
            <i id="dialog-minimize" class="fa fa-fw fa-window-minimize"></i>
            <i id="dialog-close" class="fa fa-fw fa-lg fa-times"></i>
        </div>
    </header>
    <div class="inner">
        <div class="dialog-content">
           <p><span>Choose the plan that&rsquo;s right for you. Digital access or digital and print delivery.</span></p>
        </div>
	        <a href="http://fowlertribune.com/subscribenow" class="btn btn-highlight" data-gh-tracker-track-event-object='{"category":"message center pop up","action":"click-action","label":"http://www.fowlertribune.com/apps/pbcs.dll/article?avis=CO&date=20200928&category=SPORTS&lopenr=200929798&Ref=AR"}'>
	            Learn More
	        </a>
    </div>
</div>

				<script type="text/javascript">
		__gh__coreData.pageData.pageType2 = "Article";
		</script>
		<script src="//cdn.gatehousemedia.com/gh-sites/global/ads/ads.js" crossorigin="anonymous"></script>
		<script src="//cdn.gatehousemedia.com/assets/2.0.477/app.min.js" crossorigin="anonymous"></script>
		<script>
window.googletag = window.googletag || {};
window.googletag.cmd = window.googletag.cmd || [];
</script>
<script>
  window.confiant = window.confiant || {};
  window.confiant.enable_integrations = ['gpt'];
  var pbjs = pbjs || {};
  pbjs.que = pbjs.que || [];
</script>
<script async="" src="https://confiant-integrations.global.ssl.fastly.net/JYokDAn2beiT-wdiDnha5IuKJm0/gpt_and_prebid/config.js"></script>
<script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore( A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");</script>
<script async src="https://js-sec.indexww.com/ht/p/183763-221412910371223.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
		<script>
		function __gh__init() {
		var delay = 100;
			var maxDelay = 45000;
			var __gh__asyncInit = setInterval(function() {
			    if (typeof $ !== 'undefined' && typeof __gh__webApp !== 'undefined') {
			    	try {
						__gh__webApp.init();
						__gh__webApp.articlePage.init();
					} catch (e) {
						console.error('webapp failed to initialize', e);
					}
			        clearInterval(__gh__asyncInit);
			    } else if (delay > maxDelay) {
			    	console.error('webapp init timed out');
			        clearInterval(__gh__asyncInit);
			    }
			    delay *= 2;
			}, delay);
		}
		</script>
		<script>__gh__init();</script>
			<script async src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js?201604-1" crossorigin="anonymous"></script>

		
<!--currenttimestamp: 2020-09-29&nbsp;10:14:20-->
	</body>
</html>
